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Abstract—As the latest quality control application, JMP has 
more advantages than Minitab, which is commonly used recent 
years, for it has better capability of dealing with data, mining 
data and its good automation ability, therefore, it can be used 
to analysis on batch data. At the other hand, simulation 
software Flexsim can obtain valid quality information of the 
products by modeling the produce process, in order to 
complete prior prevent and mass customization manufacture 
quality control effectively. So, this paper focuses on the design 
of open interaction system based on the good automation 
ability of JMP through both static and dynamic method to 
improve the efficiency of quality control system. 
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I. INTRODUCTION 
Mass Customization (MC) refers to the customization of 

any number of products for a single customer or a market 
with special needs at the cost and speed of mass production. 
MC is the derivation and improvement of traditional mass 
production mode under market demand. The original 
intention of mass customization production is to reduce the 
cost waste caused by product diversification, reduce 
enterprise inventory, and obtain more profit space, so as to 
improve the competitiveness of enterprises. The quality 
control system of mass customization production is based on 
continuous improvement of production. It emphasizes pre-
prevention and total quality management, pays attention to 
self-detection in modules, and makes proper use of multi-
varieties and small batches of statistical process control 
while on-line testing. At present, multivariate quality control 
is the main means of mass customization production quality 
control. Quality simulation and quality process statistics are 
the main quality control methods in manufacturing stage and 
inspection service stage, respectively. In the aspect of 
system simulation, Flexsim, an object-oriented visualized 
3D modeling and simulation software, can obtain quality 
data by simulating the production process of products. At 
the same time, Flexsim has good secondary development 
ability and can interact with other tools. In the aspect of 
quality statistics, JMP, as the latest cross-platform tool, has 
more powerful data processing ability, openness and script 
automation ability than the most commonly used quality 

analysis software, and can better complete the quality data 
statistics in production. However, depending on the separate 
operation of the two software, it cannot meet the 
requirements of mass customization production quality 
control in real time and effectively. Therefore, it is 
necessary to have an open interaction between them: 
Flexsim is used to simulate the mass customization 
production process, and the quality data are shared with 
JMP in real time for statistical analysis, so as to quickly and 
accurately study the quality level of the whole production 
process. This paper focuses on the design and application of 
Flexsim/JMP-based interactive system. 

II. DESIGN OF FLEXSIM/JMP OPEN INTERACTIVE SCHEME 
The overall design scheme of the open interactive 

system based on Flexsim/JMP is shown in Figure 1. Flexsim 
simulates the production process and records the data. It 
connects with the underlying statistical software JMP 
through middleware (static without middleware). This 
interaction scheme is divided into static and dynamic. Static 
mode does not pass through Middleware and the simulation 
data in Flexsim is exported directly through Excel menu 
command, while JMP accesses the data table offline. The 
design of dynamic connection mode needs to choose the 
appropriate interaction mode by comparing the support 
interfaces of Flexsim and JMP. 

 
Fig. 1. System structure diagram 
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Flexsim's interaction ports are divided into three types: 1) 
Open database connection is used to complete the 
connection with Access, Oracle and other databases; 2) 
Dynamic data exchange connects with Excel which has been 
opened, and reads or writes a data table at the same time; 3) 
In other ways, commands such as Flies or Socket are used 
for real-time data communication. 

The connection between JMP and external program can 
be divided into static and dynamic. Dynamic interface not 
only supports data exchange with external program through 
scripting in JSL language, but also can share data through 
external programming language such as VB and VC++, 
epecifically as shown in Table I. 

TABLE I.  HOW JMP ACCESSES EXTERNAL DATA 

Connection Type Object type Description 

Static 
connection 

No 
ODBC 
driver 
support 
required 

Internet 
Network connection, open in 
text form, web page and data 

table 
Text file Open txt type file directly 

SPSS file 
Used for statistical 

connection with SPSS 
statistical software 

Excel Displayed in JMP as a data 
sheet 

Minitab file Can directly access the files 
generated by minitab 

Need 
ODBC 
driver 
support 

Database file 
(.dbf,ndx, mdx) 

Need a corresponding V3+ 
driver 

Access file 
(.mdb) 

Need a corresponding V3+ 
driver 

Dynamic 
interaction 

By JSL 

Real-time data 
processing 
(datafeed) 

Connect to external ports of 
other machines to complete 

data exchange 

Dynamic link 
library (DLL) 

Extend JMP functionality by 
loading dynamic link 
libraries through JSL 

Socket 

Divided into streaming 
sockets and datagram 
sockets, usually data 

exchange with web pages 
EXCEL data 

sheet 
Real-time interaction with 

data in JSL/VB and EXCEL 
Through 
external 
VB,VC++
, etc. 

OLE 
automation Use VB to automate JMP 

Considering the interface characteristics of JMP and 
Flexsim, this paper uses Excel as the middleware. Through 
its powerful open ability, it accepts the data of the real-time 
simulation system and shares it with JMP at the same time. 

III. DEVELOPMENT OF OPEN INTERACTIVE SYSTEM BASED ON 
FLEXSIM/JMP 

A. Development of Offline Interactive System 
Flexsim can export emulation results as Excel tables with 

the option of its own menu bar, while JMP can access local 
databases offline through the ODBC feature. 

1) The simulation data table is derived from Flexsim: 
In the Flexsim menu bar,operator can select Data > Data 

and Report, select the relevant data in the list, click Generate 
Report, and the required data will appear in Excel form. 
Alternatively, you can click on the Excel icon in the toolbar 
to find the table you want to export in the dialog box. 

2) JMP accesses local data through ODBC: 
In JMP (version 10.0), click File > Database > open the 

table, you can select the connection in the dialog window, 
select the "Excel files" user data source in the machine data 
source, and select the tables you want to access in the 
workbook dialog box, for example (quality. xlsx). 

 
Fig. 2.  Accesses quality parameters through ODBC 

In this dialog box, you can select the specified worksheet 
and set the imported data rows through the SQL query 
statement. 

 
Fig. 3. Opens the table interface from the database 

B. Development of Online Interactive System 
The dynamic interaction between Flexsim and JMP is 

realized directly in Excel by automating JMP, in VB 
language. 

Flexsim, the top-level simulation system, can exchange 
real-time data with Excel through DDE. The specific 
command set is as follows: 

Excellaunch ( [ strlaunchdir])  /open the Excel program, 
such asExcellaunch ( “C:\Program Files (x86)\Microsoft 
Office\Office12”) 

Excelopen (str workbook)   / open Excel files, such as 
Excelopen ( “quality.xlsx” ) 

Excelsetsheet (strsheetname)  / specify worksheets, such 
asExcelsetsheet ( “sheet1” ) 

Excelclose( num save[1/0])  /close Excel files, such as 
Excelclose (true)  

Excelquit()         / shut down Excel 

At this point, the connection between Flexsim and 
Excel's DEE is completed, and the simulation data in 
Flexsim will be transferred to Excel table in real time. 

The dynamic interaction between Excel and JMP is 
accomplished by VBA in Excel.You can select the 
development tool > Visual Basic > tool > reference in 
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Excel's menu bar, as shown in the dialog box to find JMP, 
check and confirm. 

 
Fig. 4. Adding JMP Dynamic Link Library to VBA 

First, you need to define global variables, click VBA 
Project > Insert > Module, and enter the following code: 

 
Fig. 5. VBA interface 

Public MyJMP as JMP.Application  / Define JMP 
applications 

Public DT as JMP.DataTable   / Define JMP data tables 

Public DocOpen as Boolean   / Mark whether the JMP 
data table has been opened 

In interaction, several points need to be noted: when 
changes in Excel occur on the first line, JMP does not reflect 
them;When the number of rows that occur exceeds the 
number of rows that JMP is now tracking, JMP 
automatically calls the AddRows function to create new 
rows. 

According to the JMP statement invocation rules shown 
in the following table, the main module commands invoked 
are as follows: 

Public Counter As Integer  /Count to ensure data updates 
after every five changes 

Public JMPDoc As JMP.Document/Declare JMP file 

Public CChart As JMP.ControlChart/Declare JMP 
control chart 

Public ChartOpen as Boolean /Track Chart Opened 

Public DB As AUTODB 

Set MyJMP = CreateObject(“JMP.Application”) 
MyJMP.Visible=True  /Enable JMP applications to be 
visibleCounter = 0  /Initialize variablecounter 

Private Sub Workbook_SheetChange(ByValSh As 
Object, ByVal Source As Range) 

Counter = Counter + 1 

If (Counter Mod 5 = 0 Or Counter = 1) Then  /When five 
changes occur, the update is transmitted to the control chart 
in JMP 

If Not (ChartOpen) Then 

Set CChart = JMPDoc.CreateControlChart /New control 
chart 

CChart.LaunchAddProcess "Column 1" /Add column 

CChart.LaunchAddSampleUnitSize 5 /Set sample cell 
size 

CChart.LaunchSetChartTypejmpControlChartVar /Set 
chart type 

CChart.Launch / Startup chart 

ChartOpen = True /Mark a chart that has been opened 

End If 

TABLE II.  JMP SUBROUTINE DESCRIPTION 

Subroutine (object 
name_event name) Explanation 

Workbook_Open 
Called when the table is initially loaded to 
initialize variables, JMP, and to remind JMP to 
open the same worksheet as a database 

Workbook_Change 
When a cell of any workbook in the worksheet is 
changed, a control chart is generated in JMP 
when it is first invoked. 

Workbook_BeforeClose Called before the worksheet window closes 

IV.  APPLICATION OF FLEXSIM/JMP OPEN INTERACTIVE 
SYSTEM 

We simulate a mass customization production line by 
Flexsim (Fig. 6), monitor the weight of the product in real 
time, and control the quality of the weight index. 

Firstly, add labels for product weight parameters in 
Flexsim, such as: 

Addlabel(obj object, strlabelname) /Add labels to entities 

Setlabelstr(obj object, str/num label, str value) /Set tag 
name 

Setlabelnum(obj object, str/num label, numvalue) /Set 
label value 

 
Fig. 6.  MC simulation overall operation diagram 

Flexsim and JMP are connected by the dynamic 
interaction method in Section 3.2 above. The weight of 40 
continuous products produced by pipeline simulation is 
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analyzed by JMP control chart. The size of subgroup is set to 
5, and the Xbar-R control chart is obtained as shown in 
figure 7/8.According to the position of the points in the chart 
on the middle line, the weight index of the product can be 
judged, and the eight criteria for judging the difference of the 
standard reference control chart can be judged.(GB/T 4091-
2001)  

 
Fig. 7. Xbar-R Control Chart of Weight Index (Mean Chart) 

 
Fig. 8. Xbar-R control chart of weight index (range chart) 

In the mean control chart shown in Fig. 7a, the marked 
abnormal points can be seen. According to the first criterion 
"one point falls out of area A" and the fifth criterion, "two 
points fall out of area B on the same side of the central line in 
three consecutive points", the abnormal process can be 
judged, and the abnormal phenomena can be classified 
according to the Six Sigma management method. Analysis 
and improvement, and re-monitoring of production 
simulation quality data, so as to ensure product quality. 

V. CONCLUDING REMARKS 
As a newcomer in quality control software, JMP can 

effectively share data with database and system simulation 
software in real time. It is the first time to carry out 
comprehensive quality control for the products of simulation 
production line, so as to solve quality Control of Mass 
Customization Production with low cost and high efficiency. 
As a newcomer in quality control software, JMP can 
effectively share data with database and system simulation 

software in real time. It is the first time to carry out 
comprehensive quality control for the products of simulation 
production line, so as to solve quality Control of Mass 
Customization Production with low cost and high efficiency. 

Based on the simulation software Flexsim as an example, 
according to its characteristics of external interface, and 
JMP itself script automation ability, designs the simulation 
based on Flexsim/JMP quality control system, make both 
can real-time data sharing, and application in mass 
customization production, give full play to the advantages 
and JMP Flexsim simulation statistical advantage, effective 
for the production enterprise provides a train of thought to 
solve the quality control problem. 
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